The Serial Port Data Logger module allows the geoDVR to automatically log all raw data received to a COM (RS232 Serial) port during each recording session, allowing for custom data acquisition with the geoDVR.
Data recorded using the Data Logger module are automatically split according to each recording session, and the data is stored on the designated data drive (usually the D: drive) along with the videos, image captures and geospatial data (GPX). The data dumps are named for each session and each Data Log ends with the .BIN file extension.
Configuring the Data Logger Module
You will need to configure the Data Logger Module to suit the device connected to the COM port. The device must be capable of outputting to Serial/RS232 format.
To access the Data Logger Settings, click on the Options menu > Data Logger > Log Serial Port Data.

Overview of Settings

NOTE: Please consult your device’s documentation for the Serial Port settings needed.
- COM Port: This is the COM port the device is connected to.
- Baud Rate: The baud rate (bit transfer rate) the device uses.
- IMPORTANT: This must match the device’s rate exactly or else binary data will be logged incorrectly.
- Parity: None is the default. This is the common setting and usually does not need to be changed.
- Data Bits: 8 is the default. This is the common setting and usually does not need to be changed.
- Stop Bits: One is the default. This is the common setting and usually does not need to be changed.
- Handshake: None is the default. If a different handshake is used by the device, please select it here.
Once you have entered the settings correctly, press OK. The settings are applied immediately.
Checking the Incoming Data
You can check the incoming data being received by the COM port by selecting Options menu > Data Logger > Show Data Logger Output. This will output all received data to the geoDVR’s System Output window.

NOTE: It is recommended to keep Show Data Logger Output OFF during missions, as this can negatively impact the geoDVR’s performance. The data will still be logged even when it is not being displayed in the System Output window.
Saving the Settings
Once the settings are correct, click the File menu > Save Current Settings as Default to save the Data Logger settings. This will automatically apply the new settings every time the geoDVR is started.
Toggling Data Collection Module
The Data Logger module can be turned off by clicking Options > Data Logger > Log Serial Port Data a second time.
Clicking it again will bring up the configuration and enable the module. If the Data Logger module is enabled, you will see a checkbox next to the menu option, along with the Port Logger (PL) status indicators at the bottom of the geoDVR interface.

NOTE: The menu option File > Save Current Settings as Default will also save whether or not to enable the Data Logger Module. Be sure this module is enabled (has a check box) when using Save Current Settings as Default, or the module will not run and serial data will not be recorded.
Status Indicators
When the Data Logger Module is enabled, you will see two status indicators near the bottom of the geoDVR interface:
![]()
- Port Logger (PL) Connected: Red (No) if 0 bytes of data are being received at the COM Port. Green (Yes) if bytes of data are being received at the COM port.
- PL Recording: Red (No) if the Data/Port Logger (PL) is not currently saving data to a .BIN file. Green if it is
During a recording session, both status indicators should turn Green if the module is set up correctly.