April 14, 2018

Documentation – LineVision Google Earth Extension

LineVision Google Earth

1.Overview of LineVision Google Earth

LineVision™ Google Earth

User Manual (Pro & Viewer)

Simple Software for Geospatial Video, Photo & Document Mapping, Data Analysis and Project Reporting Using Google Earth

Contact:

Remote GeoSystems, Inc.
3307 S College Ave.
Suite 211
Fort Collins, CO
80525 USA
+1 970.367.7808
info@remotegeo.com

 

1.1.About

LineVision Google Earth is a stand-alone desktop software that leverages Google’s popular 3D globe to map, analyze and package geospatial Full Motion Video (gFMV™), photos, documents, KML files and raster imagery.

Now anyone can easily view this valuable asset location-based multimedia using the world’s most popular 3D mapping application.

Finally, there is an easy and affordable way to create and distribute multi-source data analysis work products without having to learn the details and workflow of traditional GIS software, but still using those valuable resources.

This easy-to-use desktop software is one of the most “open” and versatile geospatial video analysis tools available.

You can load properly formatted video from a variety of COTS cameras, specialized geospatial DVRs, and gyro-stabilized systems, including our own Remote GeoSystems geoDVR™.

Simply click any point along the path to geographically “navigate the video” to that exact location. As the video plays, a cursor moves along the GPS track, continually indicating the location where you captured the video. If you see something of interest in the video, you may pause and “snap” a still image from the video. This snapshot is geotagged and saved as part of a .geoProject™ file for data portability and future analysis.

LineVision Google Earth can play up to 4 simultaneously collected geospatial video files, enhancing the capabilities and value of modern multi-sensor gimbal cameras and mobile mapping systems.

The geoProjects created and saved in LineVision Google Earth – Pro can be opened and reviewed in LineVision™ Esri ArcGIS – Pro and Viewer and LineVision Esri Maps Basic, Pro, and Ultimate.

LineVision Google Earth is available in both Professional and Viewer editions. For a comparison of the two, please see the Pro versus Viewer comparison in the Appendix.

Key Features:

• Open & Create Portable geoProject Files Packages

• Map-based Playback of Geo-referenced video files

• Multichannel HD & SD Video Viewing

• Simple import and viewing of High-resolution Oblique still photos

• Snap & Save Geotagged Photos from video

• Add & Edit Documents and Files Right on the map

• Create & Import Asset Inspection Flight Lines

• Add local Shapefiles & Raster Satellite/Aerial Imagery

• Connect to ArcGIS for Server & ArcGIS Online

Explanation of geoProjects

A geoProject file is a standard Remote GeoSystems open-format, and “Patent-pending” method for building, saving and collaborating on location-based, immersive, rich media data products and reports.

geoProjects may include any one or all the following rich media and geospatial data types:

• Videos (with and without continuous geotagging)

• Photos

• Documents & Files (PDF, MS Office, CAD files, etcetera)

• POI Waypoints & Keywords

• Satellite & Aerial Imagery or “Raster” GIS Map Data

Using geoProjects over traditional methods gives your projects portability, immersive content that is easily marketable.

 

1.2.Specifications

Geospatial Video File Support:

File Format .MP2, .MP4 (H.246), .AVI (MPEG), .MOV
GPS Companion File Format GPX, XML, CSV, KML, SRT (DJI UAVs), & Sony GPS log files
Embedded GPS Metadata Remote GeoSystems “Whisper” (Persistent GPS Encoding)

 

Geospatial Photo Support:

.JPEG GPS metadata in EXIF header

 

Other Geospatial Data Support:

.Supported Files  KML/KMZ (Google Earth format)

 

Geospatial Project Packaging:

Single PC, Local Network or Portable Drive Remote GeoSystems .geoProject file
Portable Project File Remote GeoSystems .geoProject “Uncompressed” file

Remote GeoSystems .geoProject “Pack & Go” .RGS file (similar to a zip file)

2.Installation and Registration

2.1.System Requirements

Before you install LineVision Google Earth, make sure your system meets these hardware and software requirements:

Minimum
Processor: Intel Core i3 or better
Ports: (1) USB 2.0
RAM: 4GB Minimum
Hard Drive: 320 GB Minimum (or more depending on recording length. Video files can take a considerable amount of hard drive space; be sure you have ample free space.).
Video Card: minimum of 1 GB of memory
Operating System: Windows 7 or newer

Recommended
Processor: Intel Core i7 or better
Ports: (2) USB 3.0, (1) eSATA if collecting data from the geoDVR
RAM: 12GB Minimum, (Windows 7, 64 Bit or better)
Hard Drive: 1 TB Minimum (or more depending on recording length. Video files can take a considerable amount of hard drive space; be sure you have ample free space.).
Video Card: minimum of 2 GB of memory
Operating System: Windows 7 or newer

2.2.Downloading the Software

The download link for the software is within the email sent to the email address entered in the request form. Click the link to be directed to the version of the software that you requested and/or purchased.

NOTE: Some web browsers may not recognize LineVision Google Earth and often flag it as dangerous. The error is a false. Select Accept, Allow, or Continue.

NOTE: Even though the installer tells you to close all open applications, it is okay to leave this document open while installing.

2.3.Software Installation

Download and installation procedures are the same for all versions of LineVision Google Earth.

1. Double-click the setup.exe file in the extracted (unzipped) LineVision Google Earth folder.

IMPORTANT! If you are running Windows 8 or 10, you may encounter a security warning. Select Run or More Info > Run Anyway… to continue.

SmartScreen Warning

2. Select the Next button once the LineVision Google Earth installation wizard launches.

Install Wizard

3. Read the License Agreement and click the I Agree radio button. By clicking on the I Agree button, you have accepted the terms of the License Agreement. Click the Next button.

License Agreement

4. Select the Next Button. We recommend you keep the default Installation Folder. You also have the option of allowing just yourself or anyone using the PC to access LineVision Google Earth. Select the Next button

Install Folder

5. Select the Next button to confirm the installation.

6. The software will automatically install onto your PC.

IMPORTANT! You may have to allow this app to make changes. Select Yes.

UAC Allow Changes

7. Software Installation of LineVision Google Earth is now complete. Check the box to launch the Remote GeoSystems Codec installer. Then click the Close button.

Install Complete

2.4.Installing Google Earth and Video Codecs

Once the installation is complete, the installer is defaulted to launch the Remote GeoSystems Codecs Installer. This installer prompts you to install the necessary codecs to play the video formats used with LineVision Google Earth.

Google Earth and Codec installer

Install Google Earth

If you have not already installed Google Earth or Google Earth Pro, click the Browse to Google Earth Website button to be directed to the website.

At the time of this publication, Google had made changes on the Google Earth website that requires some additional steps to obtain the desktop version.

IMPORTANT! Be aware that Remote Geosystems has no control over changes Google makes to their website or software. Direct any questions you have about either the website or Google Earth to Google support.

To download Google Earth from the website:

  1. Either click the button Browse to Google Earth Website on the Post Requirement Installer screen (the same screen as the codecs) or navigate to http://google.com/earth.
  2. Click on Older Versions.
  3. Click on Download.
  4. Click on Agree and Download.
  5. Navigate to your download and double-click on GoogleEarthProSetup.

Adjusting the Google Earth cache

The last installation step is to increase the cache size for Google Earth.

To increase the cache size:

  1. Open Google Earth Pro by double-clicking the icon on your desktop, or under Programs, go to Google Earth Pro.
  2. Click on Tools, then Options.
  3. Click on the Cache tab.
  4. Change the Memory Cache Size to 1000.
  5. Set the Disk Cache Size to 2000. If this is already at 2000, no change is necessary.
  6. Click on the Apply button, and then the OK button.
  7. Click on File, and then Exit.

Install geoDVR Codecs

We strongly recommend installing the geoDVR Codecs even if you do not plan to use a geoDVR.

Install Optional Codecs

If this is your first time installing any of the LineVision software titles, make sure to install the Optional Codecs.

Once the LineVision Google Earth software and Codecs have installed, you may click Close to exit this window.

 

2.5.Register LineVision Google Earth

NOTE: You need to have an active Internet connection to complete your one-time registration.

IMPORTANT! Your LineVision Google Earth software license key is unique to a specific PC and is non-transferable. Do not enter the license key on a computer you do not intend to use LineVision Google Earth on for long term. If you need to transfer a license to a new PC, please contact Remote GeoSystems for help at 970-397-7808 or info@remotegeo.com.

1. When LineVision Google Earth launches, the software prompts you to enter your software license key. You may copy and paste it from your registration email into the registration window

NOTE: If you are using the 7-day trial, be aware this screen will open each time you launch the software. Simply click Continue to keep using the software during your trial period.

Registration Window

2. Click the Continue button.

3. In a few seconds, you should receive confirmation that your software is successfully registered.

 

3.Application Interface

NOTE: This manual covers the Pro and Viewer editions of LineVision Google Earth. Features only available in Pro will be tagged (Pro only). You may also refer to the feature comparison.

Once you launch the software, the application appears by default with the Video Viewer, Photo ViewerMedia Browser and Map Navigation in the default layout. As with traditional Windows programs, there is also a Menu Bar across the top.

Google Earth Default Layout

 

 

 

 

3.1.Viewers & Panels

Video Viewer / Photo Viewer:

This panel shows the Video Viewer and Photo Viewer panels for a geotagged video stream, digital photo, or audio stream, respectively. You may select which one to display by clicking on the associated tab.

NOTE: When you load multiple geo-synchronized videos, additional Video Viewer Panels are shown, by default, below the Map Viewer Panel. You can change the Panel layout by dragging and dropping the panel into the desired location.

 

Video Viewer

Video Viewer panel

  • The arrows advance the video forward or backward. How far or little depends on the time entered in the Set Video Skip Forward/Back Time.
  • While the video plays, the GPS information shows the spatial track.
  • Speed is measured in knots

Photo Viewer

Photo Viewer panel

  • The disk with a green arrow pointing at it saves the photo.
  • The magnifying glass allows you to zoom in and out of a photograph.
  • The box with the orange arrows fits the image to the photo viewer screen.
  • The blue buttons with arrows rotate the photograph clockwise or counterclockwise.

 

Media Browser Panel

This panel shows a thumbnail image representing videos, photos, audio clips, and annotations.

3.2.1.File Menu

GE File Menu

NOTE: The red boxed items are only available in Pro.

Open Single Video:

Select this menu item to navigate to your video. If your video has a GPS “companion file” within the same folder, or you recorded your video with the geoDVR, then your video automatically loads and zooms to the recorded location on the background map. For more information on working with videos, see how to open a single video

Open Multiple Videos: (Pro only)

This menu is available for very particular use cases. For more information on the feature, see how to open multiple videos.

Open multiple videos

 

Open Photos:

Select this menu item to bring one or more photographs to LineVision Google Earth. You can bring in photographs that are geotagged, screenshots from videos, and photographs without geotagging.

Save: (Pro only)

This will save your current work so that you can restore and work on it later. For more information on working with videos, see Using the Different Save Options.

Save Current Local geoProject: (Pro only)

Essentially the same functionality as above but allows you to give your geoProject a new name. For more information on working with videos, see Using the Different Save Options.

Save Portable Uncompressed geoProject: (Pro and Ultimate only)

Select this menu item to save your LineVision Google Earth project as an uncompressed .geoProject file. For more information on working with videos, see Using the Different Save Options

Save Portable Compressed geoProject (.rgs file): (Pro and Ultimate only)

Select this menu item to save your LineVision Google Earth project as a compressed or zipped geoProject file (.rgs). For more information on working with videos, see Using the Different Save Options

Close All: (Pro only)

Select this menu item to close all assets such as videos, photos, documents, etc. in the Media Browser and Video/Photo Viewer. Be aware that if you have not saved your project, any changes you may have made will be lost.

 

Open Remote geoProject: (.geoProject file)

Select this menu item to open a previously saved .geoProject file on your PC, local area network, or external drive. For more information on the different open options, see Opening a geoProject

 

Extract and Open geoProject: (.rgs file)

Select this menu item to extract and open a previously saved portable ‘Pack & Go’ geoProject (.rgs file). For more information on the different open options, see Opening a geoProject

 

Save Current Layout & Settings as Default:

This menu option lets you save a custom layout of the panels and will load the layout the next time you launch LineVision Google Earth.

 

Advanced Settings & Window Positioning

Advanced Settings menu

Load Saved Layout Settings: Select this menu to restore your custom default layout settings if you have changed them while working on your LineVision Google Earth project.

Reset Settings to Factory Default: Select this setting to restore the panel layout to the standard 3-panel layout.

Exit:

Selecting this menu item closed LineVision Google Earth.

IMPORTANT! If you want to return to your current project, be sure to Save it as a geoProject file before exiting the program. However, if you want to be able to move your project from one computer to another use Save as Portable Compressed or Uncompressed geoProject (Pro only).

3.2.2.Options Menu

GE Options Menu

 

Enable Audio/Video Chaining:

Enable Audio/Video Chaining jumps from one video track to the next in sequential order when you load more than one video clip. The is ideal scenarios for this is when the geoDVR or other geospatial DVRs are recording at a preset time or size limit. It is recommended to leave this option checked.

Camera Projection Settings:

Select this menu item to calculate the position where the camera is pointing or to estimate a trace from a location in the air to a location on the ground. See Using Camera Projection Settings for more information.

Maintain Video Aspect Ratio:

Check this menu item if you want the video aspect ratio to remain consistent when you move and resize the video panel. It is recommended to leave this option checked.

Enable GeoFence:

Check this menu item if you want a circle located under the current position marker showing where the GPS point with the specified radius overlays the map. Manually enter the feet you would like the circle’s radius to become. Press ‘OK’

.GeoFence Options

Limit GPS Frequency to 1 Hz:

Check this menu item if you logged video with a higher GPS frequency and want to “de-cluster” the GPS points along a path. It is recommended to leave this option checked.

Pan to Media on Click:

Check this menu item if you want the map to “pan” to the start location of the video or point location of the photo or annotation. It is recommended to leave this option checked.

Play on Click Settings:

Check this menu item if you want videos to begin playing from the map location at which the path was clicked. By default, Pause Video at Click Location is checked.

Always Ask for GPS Companion File:

Check this menu item if you want LineVision Google Earth always to ask which GPS companion file you would like to use with the video. The default is unchecked which means the application will attempt to identify companion files with the same name as the video. If LineVision Google Earth does not see a GPS companion file, it will then ask you to select a corresponding companion file. Selecting this option is recommended if your GPS companion files usually have a different name than the corresponding video file.

Warn On Missing Timecodes:

Check this menu item if you want LineVision Google Earth to show a warning message if timecodes are not detected in the video’s companion file. By default, this option is NOT selected.

If unchecked, LineVision Google Earth will automatically interpolate the timecodes. If timecodes are interpolated, there may be significant differences between the video position and the position on the map.

Check this menu item if you want LineVision Google Earth to compare the length of the video to the length of the GPS points making up the video track.

Companion File mismatch menu

  • Always: When checked, the length of the video is always compared to the length of the video track. If the length is not within a tolerance, a warning message is shown.
  • Only When Edits Aren’t Possible: When checked, the length of the video is checked against the length of the video track only if the LineVision Google Earth algorithm determines that the video track has not been edited.
  • Never: When checked, the video length is not checked against the video track length. It is not recommended that Never be checked unless video track editing has occurred and you know that the video’s length will not match the track length.

Turn Off Video Hardware Acceleration:

Select this menu item if you have an older computer or if you are running software that is very demanding on graphics and system resources. Since LineVision consumes a lot of resources when playing videos, you can improve the performance of your computer by leaving this menu item checked.

Set Video Skip Forward/Back Time: (Pro only)

Select this menu item if you want to set the frame rate to skip forward and backward in your videos.

If for example, you want to skip forward 1/10th second per frame, you would enter 0.1. If you want to skip forward 1/5th second per frame, you will enter 0.2

Back and Forward buttons

Video Skip Time Adjustment

Auto Adjust Map for Current Video Position:

Select this menu item if you want the map to automatically pan and re-center itself when the current video position cursor (yellow balloon) moves off the screen.

Watermark Captured Images with GPS Data:

Select this menu item if you want to snap a photo from video and overlay or “watermark” the image with latitude, longitude, date, and time.

Watermark Captured Image

3.2.3.Google Earth Menu

GE Google Earth Menu

Set to United States View:

Selecting this menu item will default the map view panel to center on the United States when you launch LineVision Google Earth.

Set to World View:

Selecting this menu item will default the map view panel to center on a global view when you launch LineVision Google Earth.

Set Path to Exe:

If you install Google Earth in a directory different from the default, you can use this menu to change the directory path.

 

3.2.4.Advanced Menu

GE Advanced Menu

NOTE: Advanced Menu available in Pro edition only.

 

Create KLV Video File:

COMING SOON

Load KML/KMZ File:

Select this menu item if you have geographic data in a KML/KMZ format. For example, data might include pipeline leak-detection sensor data, utility, and pipeline asset network, patrol waypoints, or vector and imagery data.

NOTE: KML/KMZ files imported into LineVision Google Earth – Pro may not display all the data elements visible in LineVision Google Earth.

Load GPS Track/Waypoint without Video:

Select this menu item if would like to load a GPS track or waypoint file without video such as a track log from a handheld GPS unit

Load Waypoints

 

Launch Remote KMZ to KML Converter:

This utility converts a Google Earth KMZ (zipped) file to a Google Earth KML (unzipped) file.

KMZ to KML Converter

 

Extract GPS Data from geoDVR Video:

Select this menu item to create a new GPS companion file from a geoDVR video file. This is usually only used if the original geoDVR video file has been edited in an external program like Adobe Premiere or Final Cut, or if the original geoDVR video companion file has been lost.

NOTE: This feature is only available if your video was geotagged using Remote GeoSystems “Whisper” video geotagging method (available with geoDVR.)

 

Launch Remote Photo GeoLocator:

Select this menu item to open the remote GeoSystems Photo GeoLocator to geotag non-geotagged photos or to re-geotag previously geotagged photos to a new location (Figure 316). For more information on this menu item, see How to use the Remote Photo GeoLocator.

Combine Companion Files:

Select this menu item to combine one or more GPS companion files that were collected in chronological order

Combine Video GPS companion files

 

Repair geoDVR Video File:

The Repair geoDVR Video File is used to fix video files that have become corrupt. This typically happens when the geoDVR is shut down without stopping the recording first.

Enable Performance Handling:

This menu item reduces the number of GPS points based on zoom level to optimize performance. If you wish to see all the GPS points, make sure you uncheck Enable Performance Handling.

NOTE: Unchecking Enable Performance Handling may cause a drop in the performance of LineVision Google Earth.

 

Specify H.264 Decoder:

The Specify H.264 Decoder function is used should there be an interlacing problem occurring during video playback.

NOTE: We recommend using the System Default as these are very advanced options.

The options include:

  • Blending
  • Motion
  • Triangle Filtering
  • Standard Default

 

3.2.5.Window Menu

Window menu

The Windows Menu allows you to backup and restores your application settings and custom layout. The Windows Menu is for situations where you or your clients might be using multiple copies of LineVision Google Earth on different PCs and need to move data files around, but also want to transfer their application settings and windows layout.

Backup Settings & Window Locations:

Selecting this menu item will let you choose the folder location to save your application settings and custom layout as an .XML file.

Restore Settings & Window Locations:

Selecting this menu item will let you choose the folder location where you previously saved your application settings and custom layout as an .XML file so that it can be restored.

Show Layer Control:

This restores the Layer Control tab when it has been closed.

3.2.6.Help Menu

Help Menu

 

Email Program Logs:

Select this menu item to report any errors should they occur while using LineVision Google Earth. A window will pop up and ask you for your information. The application’s program log will automatically be attached to the email.

Email Program Logs

About:

Select this menu item to determine your LineVision Google Earth software build/version number. Remote GeoSystems technical support may ask for this number when resolving support issues.

 

4.Media Browser Functions

Right clicking on an item in the Media Browser will open a contextual menu with additional options to manipulate and work with videos, files, and annotations.

GE Media Browser

Zoom to… (Photos and Videos)

Use the Zoom to… function when you are trying to find the Map Viewer location that corresponds to the image, video, or audio file.

Fit All Media in Map (Photos and Videos)

This function places all the files in the Media Browser on the map altogether.

Jump to Time (Videos only)

Use the Jump to Time function when you are trying to find a section of the video that corresponds to some other data type, such as data from a gas leak detection alert. In these cases, the geoDVR and leak detection system may be logging the same GPS data stream. After you have selected Jump to Time, a screen pops up to allow you to input the Hour, Minutes and Seconds and click the Jump to Time button to go to this same time in the corresponding video.

Jump to Time

Show all GPS points:

If your video has over 1000 GPS data points, the software automatically limits your video to 1000 to improve performance. By selecting this menu option, all GPS data points are shown on the map.

NOTE: This option only appears if waypoints are hidden.

Remove item:

This will remove the item you have right-clicked on.

Browse Waypoints (Video and Audio Files)

NOTE: This option only appears if there are waypoints in the file.

The Browse Waypoints function is an alternate way to browse all the Waypoints associated with the video. See Using the Waypoint Browser for more information.

Save Track as a GPX File (Only in Pro)

NOTE: This option only appears if there are waypoints in the file.

If you want to use only the GPS data from the media, this will export it to a GPX file

Extract Waypoints as GPX File (Video and Audio Files)

NOTE: This option only appears if there are waypoints in the file.

The Extract Waypoints as GPX File creates a .GPX file from the Waypoints associated with a video or audio file. After you have selected Extract Waypoints as GPX File, a File Explorer window opens asking where you would like to save the GPX File

View Info

This will display details information about the item, including Start Latitude/Longitude/Altitude/Time, number of GPS Points, GPS frequency, Waypoints and other data.

View Info

 

 

5.Working with Video

LineVision Google Earth enables you to geospatially review post-mission video recordings by simply clicking any of the red points along the aerial or terrestrial GPS track positioned in Google Earth. The video then automatically advances or reverses to that point in the video so that analysts and subject matter experts can visually interpret the recording.

If your video’s GPS Companion File is named something different than the video file, or in a different file folder, then you will be asked to select the appropriate GPS Companion file. What this file is named may vary depending on which hardware you used to record your geospatial video and/or how you have your files named and organized.

NOTE: If the video you are loading has more than a thousand (1000) GPS points the software will display a warning.

Performance Warning

IMPORTANT! If you do not want to be reminded of the performance warnings when files exceed the GPS limit, check the Do not show this message again box. However, this message will still be displayed at the bottom of the screen, and the pop-up window will not appear again.

How to open a Single video

  1. Click on File.
  2. Click on Open Video.
  3. Select the video file you want to load.

NOTE: A GPS companion file must accompany the video file for it to load properly into LineVision Google Earth.

The video will load and begin playing. A red track will appear on Esri ArcGIS in the Map Panel showing the path of your recorded video. A yellow marker or purple with yellow center marker moves along the video path as the video plays indicating the location where it the video was recorded

How to open multiple videos

IMPORTANT! Use this option ONLY if you are loading video clips for multiple video channels collected at the same time and place such as from a multichannel geoDVR. If you are loading video clips recorded on only one video channel, or you are unsure how the files were recorded, use the Open a Single Video steps.

Typically, multiple geo-synchronized video files are recorded with geoDVRs or compatible third-party multi-channel geo-referenced video recorders. You can open up to four videos at a time.

To open multiple, synchronous videos:

  1. Click on File.
  2. Click on Open Multiple Videos.
  3. Click on Browse to open four videos at a time.

Open multiple videos

How to view info for videos

Video files View Info displays the following information: video name, companion file name, video start latitude, video start longitude, video start altitude, video start time (UTC), number of GPS points, GPS frequency, estimated video track length (in both kilometers and miles), and number of waypoints.

To view the information:

  1. Right-click on the item you want to review the information on.
  2. Click on View info.
  3. The information screen displays.
  4. To exit, click on either the X or OK.

View info window

 

6.Working with Photos

How to load geotagged photos

  1. Go to File.
  2. Click on Load Photos.
  3. Navigate to your folder in Microsoft Explorer and select the geotagged photo(s) you want to load.

How to snap a photo from video

If you observe a point of interest in the video, you may pause and snap a still image (also known as a screen capture) from the video. It is geotagged and saved in the same folder as the video. You may add it to your current or include it with a future project.

To grab a screen capture:

  1. Pause the video by clicking the Play/Pause button.
  2. Click the Camera Icon in the lower right-hand side corner of the Video Viewer panel, next to the microphone (Adjust Volume).
  3. The Image Viewer appears with a geotagged still photo from the video.
  4. Click the disk with the green arrow and disk (Save) to save the image.

How to use the Photo GeoLocator

Select this menu item to launch the Remote GeoSystems Photo GeoLocator to geotag non-geotagged photos or to re-geotag previously geotagged photos to a new location.

Photo GeoLocator

To geotag a non-geotagged photo or to re-geotag previously geotagged photos:

  1. Click on Advanced.
  2. Click on Launch Remote GeoSystems Photo GeoLocater.
  3. Click on File.
  4. Click on Open Photo.
  5. Zoom to the area of the map where you would like to geotag (geographically associate) the photo. Alternatively, you can manually enter the GPS coordinates and altitude.
  6. Click the Geotag Image button.
  7. If the photo already has GPS information saved, a warning pops up letting you know existing data will be overwritten. Click Yes to continue..
  8. A message appears alerting you that the save was successful. Click OK.

Renaming Photos

  1. Right-click on the photograph you want to rename.
  2. Click on Rename Photo
  3. A warning message appears to alert you that this action also changes the name of the file on the hard disk. Click OK to proceed.
  4. Enter a new name and click OK.

Viewing Photo Info

The photo View Info displays the following information: photo name, latitude, longitude, altitude, UTC date and time, and file size.

To access the view information screen:

  1. Right-click on the photo you want to review the information on.
  2. Click on View info.
  3. The information screen displays.
  4. To exit, click on either the X or OK.

View photo info

 

7.Working with Camera Projection Settings

Camera Projection Menu

NOTE: This feature is recommended fixed-mounted cameras only that are at least 200 feet (1 Kilometer) or more above ground.

NOTE: The results will be based on the current digital elevation model used by Google Earth; it is highly likely even in the very best cases the estimated location of where the camera is pointed will be off.

Show Estimated Camera Projection:

Select this menu item to calculate the position where the camera is pointing by inputting custom variables like Camera Tilt, Camera Pan & Average Altitude Above Ground Level.

Camera Settings

Trace (Estimated) Camera Projection:

Select this menu item to see the estimated trace from the aircraft location to the target location on the ground.

Trace Camera Projection

It is important to note that the settings dialog altitude is relative to the ground. However, GPS altitude is relative to sea level. For the math (trigonometry) to work, we must know the elevation relative to ground (which is not available via the GPS data).

Therefore, the operator must know what their average altitude relative to ground is for the projections to be accurate. Small variations do not affect the math too much although large variations (100 meters or so) could cause significant variations. The altitude variables you are seeing signify the ground height (as determined by what is inputted into the setting dialog).

For example, if you are in Colorado, the altitude of the white point should be approximately 5,280 feet (1600 Meters). Whereas at sea level, it should be close to 0. This gives the end user a “cross-check” on how close their altitude estimate is.

 

8.Waypoint Browser

The “Waypoint Browser” is triggered by right-clicking on the video icon in the Media Browser and selecting Browse Waypoints from the drop-down menu.

NOTE: If waypoints are not present in the video, this menu item does not appear.

 

Waypoint Browser

Once Browse Waypoints is selected, a new tab appears to the right of the Map Browser tab (in the lower left corner of LineVision) with thumbnails (typically only with geoDVR or a generic icon representing the different waypoint(s) appears).

If you hover above a waypoint in the Waypoint Browser, a marker highlighted in red appears on the map showing its location. Also, if you click on the waypoint thumbnail, the video will jump to the waypoint’s location.

9.Removing Project Items

You can only remove one video or photograph at a time.

To remove an item:

  1. Right-click on the item you want to remove.
  2. Select Remove Item.

IMPORTANT! There is no confirmation for the deletion.

 

10.Using the different save options

Available only in the Pro edition.

Save

This option saves your current work as a .geoProject file so that you can continue working on it later. This is the recommended method if you are leaving for lunch or the day, and will be returning to work on the project, but will not be sharing it with anyone, yet.

NOTE: this save function is best suited for “a project or work in progress,” as it saves your local “absolute” file paths to the media and data. For packaging and sharing .geoProjects, it is recommended you choose either the Create Uncompressed geoProject File (.geoProject File) or Create “Pack & Go” geoProject File (.rgs File) menu options.

Save Current Local geoProject:

This is the ‘Save As’ option for LineVision Google Earth, allowing you to save a project under a new name.

Create Portable Uncompressed geoProject:

This is the recommended method when saving a geoProject for sharing with a colleague or client.

Select this menu item to save your LineVision Google Earth project as an uncompressed .geoProject file which creates a geoProject with all files copied to a single directory or folder.

Create Portable Compressed geoProject File (.rgs file):

Select this menu item to save your LineVision Google Earth project as a compressed or zipped geoProject file. This method is recommended when saving a geoProject for sharing with a colleague or client and achieving the smallest possible folder size is important.

NOTE: Saving a compressed geoProject can take several minutes or more to create a .rgs file, especially when your project includes large video files.

 

11.Using the different open options

To open a geoProject go to File and select one of the menu items below based on how the geoProject was previously packaged.

Open a Remote geoProject (.geoProject File)

Select this menu item to open a previously saved .geoProject file or uncompressed .geoProject file on your PC, local area network or external drive.

Extract and Open a ‘Pack & Go’ (compressed) Portable geoProject (.rgs File)

Select this menu item to extract and open a previously saved portable ‘Pack & Go’ geoProject (.rgs file).

 

12.Working with an annotation

IMPORTANT! LineVision Google Earth does not support the creation of annotations. You can, however, view and edit an annotation created with LineVision Esri Maps Pro and Ultimate.

Viewing annotation in Google Earth

Annotations created in LineVision Esri Maps Pro or Ultimate will be represented by a yellow pushpin like other user added data in Google Earth. If you are unsure which pushpin icon is the annotation you’re looking at, you can use the Zoom to… function on the contextual menu of an annotation. Simply right-click on your annotation and select Zoom to…

Annotation in Google Earth

Viewing annotations within the LineVision interface (Pro only)

To view annotation information:

  1. Right click on the annotation in the Media Browser.
  2. Click on View Info.
  3. Once in this window you have the option to Edit Note, Add/View/Delete Image(s), and Add/Open/Delete Document(s)

IMPORTANT! If you select Remove Item and save your project, you cannot add the annotation back with LineVision Google Earth. You will need LineVision Esri Maps Pro or Ultimate to do this.

 

13.How to install or reinstall codecs after installation

If you installed the software and did not go through installing the codecs, you need to add codecs, or you need to reinstall the codecs, do the following:

1. On your computer go to the installation path, which by default is C:\Program Files (x86)\Remote Geosystems\

Remote Geo folder

IMPORTANT! The path for the Remote Geosystems may vary. If no changes were made during the installation, this is the typical path for Windows 7 and above.

2. Double-click on the folder for your version of the software

  • LineVision Google Earth Pro
  • LineVision Google Earth Viewer

3. Double-click the file LVGEPostSetupApp.exe

NOTE: The file ends in .exe;however, if the extensions are hidden, you will see the files as they are displayed below:

Codec installer file

NOTE: It may take a minute or two for the screen to launch.

4. Click the codec installation you wish to proceed with. We recommend installing both the geoDVR Codecs and optional codecs, even if you do not use a geoDVR.

 

14.Troubleshooting

I am having an issue with Google Earth

Remote Geosystems LineVision Google Earth is a plug-in for Google Earth, and we can only assist you with technical issues regarding any Remote Geosystems software. If you encounter any issues with the Google Earth application itself, you will need to visit the website (http://google.com/earth) or contact Google for support.

 

Companion file not found

These messages may occur when trying to open a .geoProject

Select companion file

Companion file not found

How to resolve:

  • LineVision looks for companion files with the same name as the geo-tagged video or audio. If the software does not find a companion file of the same name, the message to manually find it is triggered, and the error message follows if you click OK without selecting one. If the companion file has a different name or was renamed, click Select Companion File, and browse to the file, and then click OK. Alternatively, if the file is a Remote GeoSystems supported video, you can click Extract GPS from Video and OK to generate a new companion file. The new companion file is created in the same folder as the video.
  • If the companion file is not in the same folder as the video being opened, the software asks you to find the file manually, and the error message follows if you click OK without selecting one.
  • You can save your .geoproject as a standard save file, without collecting all the video and other files – including the companion file. If move just your .geoproject folder without using one of the portable formats, this error can be triggered if the companion file is not on the new computer. Try opening the .geoproject file on the computer it was created. If the message does not appear, then you will want to use one of the portable save options
  • The file may not be one of the file formats that LineVision can read. Verify it is a compatible format.
  • The companion file has become corrupt, or the file extension is missing or wrong.

Error loading video: Could not parse the GPX file

When you might see this error when opening a video file or selecting to repair a video file (Advanced > Repair geoDVR Video File).

What the error means the GPX or SRT file is blank, the GPX or SRT file was written or created incorrectly, or the video file has become corrupt.

How do I resolve this error?

  • Try downloading or copying the video, GPX, or SRT file to your computer again.
  • If you have received this error when attempting to use the Repair geoDVR Video File option in the Advanced menu, you may need to recreate the video or use another software to repair the video.
  • If the GPS data does not exist, however, there is no way to resolve this error.

 

Google Earth not Found

This error may occur when you launch LineVision Google Earth.

The error means that LineVision Google Earth cannot find Google Earth, and typically occurs if Google Earth was installed prior to installing LineVision Google Earth Viewer or Pro.

How do I resolve this error?

In LineVision Google Earth:

1. Click on the Google Earth menu.

2. Click on Set Path to Exe.

Google Earth Location

3. Click Browse and select the Google Earth application (googleearth.exe). This file can usually be found in (32-bit) C:\Program Files (x86)\Google\Google Earth Pro\client

 

GPS and Video Mismatch Detected

GPS Video Mismatch Detected

You might see this message when opening a video file.

What the message means the length of the video and the GPS data are mismatched.

How do I resolve this message?

  • Click the OK button to continue loading the video.
  • If the error occurred within the GPX or SRT file, you might be able to go to Advanced > Repair geoDVR Video File.
  • If the error is in the video, however, this can only be resolved by capturing the video again.

 

GPS Extraction Error

GPS Extraction Error

You might see this error when opening a video file or audio file (Figure 502).
What the error means when LineVision Google Earth tried to extract the GPS data from a video or audio file, an error occurred.
How do I resolve this error?

  • Click the OK button, and the file may load.
  • If it does not, try loading it again.
  • If the error persists, then the file either does not have GPS data, or it may have become corrupted.

 

Image Geotagging Failed

Image Geotagging Failed

You might see this error when trying to save GPS data to a photograph in Remote GeoSystems Photo GeoLocator.

Usually this error means that the coordinates selected or manually entered are too close to the previous coordinates. It has been noticed to occur when any number is changed by only 1-3 digits, or a negative sign is placed before the coordinates, but the coordinates remain the same.

How do I resolve this error?

Click OK on the failed message, and click the Geotag Image button again. In some cases, it may take several attempts to save the geotag information to the photograph successfully.

 

Map data not yet available

Map data not yet available

This error may occur when viewing track data, annotations, or the world map without data.

The error means that LineVision Google Earth cannot show the world map.

How do I resolve this error?

  • Often you see this error because the map has been zoomed in too far and there is no detail at the level zoomed. Start zooming out with your mouse scroll or the zoom bar located in the lower left corner of the Map Viewer until you can see the background map again.
  • Otherwise, you may be experiencing loss of Internet connectivity. Because LineVision Google Earth streams the world map, you must have an Internet connection for the background map to display. Verify you have an active Internet connection.

Performance Warning

Performance Warning

This message may occur when opening a video or audio file (Figure 507).

The message means that as the message indicates, the number of GPS data points should be limited to 1000 to improve map performance. This often happens when a video exceeds more than 20 minutes or covers a large area.

How do I resolve this message?

  • Click the OK button, and the video or audio file will be added to your geoProject, but there will only be 1000 GPS points showing on the map.
  • If you do get this message, and you want all the GPS data points shown on the map, you click on Advanced menu and select Enable Performance Handling (uncheck) to turn off this feature.

IMPORTANT! If you do either of these and your computer is unable to handle the excess load of the additional GPS data points, you may experience lagging or unexpected behavior from the software. You will need to either re-enable Enable Performance Handling or remove and reload the video to limit it back to 1000 GPS data points.

  • Try editing the video into shorter and smaller files. Doing this may free up resources and allow for normal performance.

 

Photo does not appear to be geotagged

Photo not geotagged

You might see this message when opening a photo or image file.

The message means that the photograph or screen capture you just loaded LineVision Google Earth does not contain geotagging information. The image will still be added, but will not appear on the map.

How do I resolve this message?

  • If you are aware that the file has no GPS data, no action is necessary, and you can disregard this message
  • If you would like to add GPS data to the photo, see Using the Remote Photo Geolocator.
  • If the photo or image is supposed to have GPS data try removing it, downloading it from the original source again, and re-loading it into LineVision Google Earth.
  • If the error persists, the photo or image is either has become corrupt or no GPS data was saved.

 

Waypoints are hidden behind other Google Earth labels

Waypoint obstructed

This issue may occur when you are trying to view your Remote GeoDVR video but other elements on Google Earth are making them difficult to click on.

How do I resolve this problem?

  • Try clicking on the group as most of the time these will expand so you can choose the correct label.
  • Try zooming in, as that will spread labels out.
  • Use Google Earth the pan/tilt control or click and hold onto the map and drag the desired waypoint up/down/left/right, until it is not grouped with other labels.
  • Turn off Google Earth Layers you don’t need. Examples of layers that most users don’t use would be The New Google Earth layer, or Global Awareness.

 

Zero Length GPS Data Detected

Zero length GPS Data Detected

You might see this error when opening a video or audio file.

What the error means the GPS data doesn’t have time recorded with it, or the UTC start time and end time are the same, or the GPS points are the same.

How do I resolve this error?

  • Click the OK button, and the video file may load. Be aware that if the software cannot detect any GPS data, however, that no track will appear on the map.
  • If this occurs, try removing the file, downloading it again to your computer, and loading it again.
  • If the error persists, the video or audio file may need to be captured again

 

 

15.Frequently Asked Questions

Do I have to do anything unique to install the software?

You do not need to do anything special or different to install LineVision Google Earth on any computer. However, for the initial installation, as with most software, you need administrator privileges. Once installed, the software is available to all users or a single user.

Can you provide the licensing information required for the application?

For the 7-day trial, there is no licensing required. To continue using it afterward, or if you choose to purchase LineVision Google Earth before the trial end, you need a license for each computer you are installing the software.

Do I need ArcMap or other Esri software to use LineVision Google Earth?

No. LineVision Google Earth is a stand-alone desktop application that leverages Esri technology and map data so that anyone without any GIS experience can create enterprise-ready immersive map-based geospatial video and photo geoProject reports.

Do you have a version of LineVision Google Earth available for Mac or Linux?

At this time, our software is only available for Microsoft Windows.

Does the application require a connection to a server or database?

While the LineVision Google Earth does require a connection to the Internet to stream background maps, it does not require connection to a database.

Does the application require any prerequisite applications to run?

LineVision Google Earth installation packages include everything the software needs to run. However, if a user opens a project saved from LineVision Esri Maps that has annotations which include documents (e.g., Microsoft Word Documents, Excel Spreadsheets, Adobe PDFs, etcetera) these can only be opened by their native applications. We do not provide these applications.

How is your LineVision desktop software licensed?

LineVision desktop software is currently licensed to a specific PC as a perpetual license and includes free updates for the first year and an optional 20% annually for upgrades in year 2 and beyond. Visit remotegeo.com to request a LineVision quote.

Who is the application owner or the technical contact?

Our company, Remote GeoSystems, Inc., is the publisher of LineVision Google Earth. Please contact us at support@remotegeo.com with any questions or technical support requests. You can also use our Support Forums.

 

16.Disclaimer

REMOTE GEOSYSTEMS, INC.’S (REMOTE GEO) SOFTWARE IS PROVIDED ON AN “AS IS” BASIS, WITHOUT ANY WARRANTIES OR CONDITIONS, EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE, OR ANY WARRANTY ARISING BY LAW, STATUTE, USAGE OF TRADE, OR COURSE OF DEALING. YOU ASSUME ALL RESPONSIBILITY AND RISK FOR THE USE OF THE SOFTWARE AND REMOTE GEO DISCLAIMS ALL LIABILITY FOR ANY LOSS, INJURY OR DAMAGE RESULTING FROM USE OF THIS PRODUCT, WHETHER DIRECT OR INDIRECT, AND WHETHER OR NOT REMOTE GEO HAS BEEN ADVISED OF OR HAS KNOWLEDGE OF THE POSSIBILITY OF SUCH LOSS, INJURY OR DAMAGE. IN NO EVENT, SHALL REMOTE GEO HAVE ANY LIABILITY TO YOU OR ANY OTHER PERSON OR ENTITY FOR ANY COMPENSATORY, INDIRECT, INCIDENTAL, SPECIAL, CONSEQUENTIAL OR EXEMPLARY DAMAGES WHATSOEVER, INCLUDING, BUT NOT LIMITED TO, LOSS OF REVENUE OR PROFIT, LOST OR DAMAGED DATA OR OTHER COMMERCIAL OR ECONOMIC LOSS, EVEN IF WE HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR THEY ARE FORESEEABLE. WE ARE ALSO NOT RESPONSIBLE FOR CLAIMS BY A THIRD PARTY. THE LIMITATIONS IN THIS SECTION SHALL APPLY WHETHER OR NOT THE ALLEGED BREACH OR DEFAULT IS A BREACH OF A FUNDAMENTAL CONDITION OR TERM OR A FUNDAMENTAL BREACH. SOME STATES DO NOT ALLOW THE EXCLUSION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES OR THE LIMITATION OF DURATION OF AN IMPLIED WARRANTY SO THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU.

ANY CONTENT OR MATERIAL DOWNLOADED OR UPLOADED OR OTHERWISE OBTAINED THROUGH THE SOFTWARE IS DONE AT YOUR OWN DISCRETION AND RISK. YOU WILL BE SOLELY RESPONSIBLE FOR ANY DAMAGE TO YOUR COMPUTER SYSTEM/NETWORK OR ANY LOSS OF DATA THAT MAY RESULT FROM THE DOWNLOAD OR UPLOAD OF ANY SUCH CONTENT OR MATERIAL OR THE USE OF THE SOFTWARE.

 

Suggest Edit