April 14, 2018

Documentation – LineVision Esri ArcMap Add-in

LineVision Esri ArcMap Add-in

1.LineVision Esri ArcMap Add-in

LineVision Esri ArcMap Add-In

User Manual

Simple Add-in for Geospatial Video, Photo & Document Mapping, Data Analysis and Project Reporting Using Esri ArcMap

Current Production Build:  Version 4.4

1.1.About LineVision Esri ArcMap Add-In

LineVision Esri ArcMap Add-In is a unique geospatial Full Motion Video (gFMV™) & Inspection Data Reporting Add-In designed for Grid and Critical Infrastructure Inspection Applications.

The all-new LineVision Esri ArcMap Add-In leverages Esri’s popular ArcMap GIS environment to map, analyze and package geospatial video, photos, annotations, documents, SHP files and raster imagery.

Now you can view this valuable asset location-based multimedia using enterprise maps and imagery provided by ArcGIS for Server, ArcGIS for Desktop and/or ArcGIS Online applications.

Key Features:

  • Open & Create Portable geoProject Files Packages
  • Map-based Playback of Geo-referenced Video Files
  • Multi-channel HD & SD Video Viewing
  • Simple import and viewing of High-resolution Oblique still Photos
  • Snap & Save Geo-tagged Photos from Video
  • Mark Features & Points of Interest with Annotations
  • Add & Edit Documents and Files Right on the Map
  • Create & Import Asset Inspection Flight Lines
  • Add local Shapefiles & Raster Satellite & Aerial Imagery
  • Leverage the Full Power of the Remote Geo & Esri Platforms via ArcGIS for Desktop

geoProjects

A geoProject file is a standard Remote GeoSystems open-format, and “Patent-pending” method for building, saving and collaborating on “location-based, immersive rich media data products and reports”.

geoProjects may include any one, or all of the following rich media and geospatial data types:

  • Videos (With and without continuous geo-tagging)
  • Photos
  • Documents & Files (PDF, MS Office, CAD files, etc.)
  • Audio Clips
  • POI Waypoints & Keywords
  • Shapefile (SHP) or “Vector” GIS Map Data
  • Satellite & Aerial Imagery or “Raster” GIS Map Data
  • URL links to Streaming Raster Imagery and other Vector Map Data

The benefits of using geoProjects over traditional methods of saving projects is that it is portable, immersive, licensed, and marketable.

LineVision Esri ArcMap Add-In is available in both Professional & Viewer editions.

Projects created and saved in LineVision Esri ArcMap – Pro can also be opened and reviewed in LineVision™ Google Earth – Pro & Viewer and of course LineVision Esri ArcMap – Viewer edition.

Please also see the Pro vs. Viewer edition feature comparison in the Appendix.

Contacting Support

For all questions about Esri ArcMap challenges or issue that do not have relation to the LineVision Esri ArcMap Add-In please contact the Esri ArcMap support staff listed below

ESRI Headquarters

380 New York Street
Redlands, CA 92373-8100

Email: support@esri.com
Phone: +1-909-793-3774
Toll-free Phone: +1-888-377-4575
Fax: +1-909-792-0960
Website Address: http://support.esri.com
Support Web Form: http://support.esri.com/en/webform

1.2.Specifications

Geospatial Video File Support:

File Format .MP2, .MP4 (H.246), .AVI (MJPEG), .MOV
GPS Companion File Format GPX, XML, CSV, KML, SRT (DGI UAVs), & Sony GPS log files
Imbedded GPS Metadata Remote GeoSystems “Whisper” (Persistent GPS Encoding)

Geospatial Photo Support:

.JPEG GPS metadata in EXIF header

Other Geospatial Data Support:

Data Files Any Esri-compatible Shape Files (SHP)
Raster (Imagery ) Files Any Esri-compatible Raster Imagery files.
Streaming Data Endpoints Any Esri-compatible Streaming Data Endpoints (ArcMap for Server, ArcMap Online, etc.)

 Geospatial Project Packaging:

Single PC, Local Network or Portable Drive Remote GeoSystems .geoProject file
Portable Project File

Remote GeoSystems .geoProject “Uncompressed” file

Remote GeoSystems .geoProject “Pack & Go” .RGS file (similar to a zip file)

2.Installation and Registration

2.1.System Requirements

Before you install LineVision Esri ArcMap, make sure your system meets these hardware and software requirements:

Minimum
Processor: Intel Core i3 or better
Ports: (1) USB 2.0
RAM: 4GB Minimum
Hard Drive: 320 GB Minimum (or more depending on recording length.  Ample storage is recommended as video files can take considerable space).
Video Card: minimum of 1 GB of memory
Software: Windows 7 or 8, Esri ArcMap 10.0 or newer

Recommended
Processor: Intel Core i7 or better
Ports: (2) USB 3.0
RAM: 8GB Minimum, (Windows 7, 64 Bit or better)
Hard Drive: 1 TB Minimum (or more depending on recording length.  Ample storage is recommended as video files can take considerable space).
Video Card: minimum of 1 GB of memory
Software: Windows 7 or 8, Esri ArcMap 10.2 or newer

If you meet these requirements, proceed to install the software.

2.2.Downloading the Software

Download the software with the link provided to you by your Remote GeoSystems contact. If you no longer have the link and need to download the software, please contact us

NOTE: Some web browsers may not recognize LineVision software and may flag it as dangerous. The error is a false. Select Accept, Allow, or Continue.

2.3.Installation

Please note you must have Esri ArcMap 10.2 or higher installed on your PC.

To install the Addin, you must first unzip the Installer. Right click on the file and click Extract All, then hit the Extract button.

ArcMap Extract Installer

Open up the LineVision-ArcMap folder that is created, then double click on setup. This will launch the installer.
NOTE: You may run in to a Windows Smartscreen error as seen below. Click More Info then Run Anyway to continue.

Smartscreen Error

Smartscreen - Run Anyway

 

The installation will continue. After the installation is completed, there should be a LineVision Arcmap folder on your desktop. This folder contains the .esriAddIn needed to install the add-in to Arcmap.

To install (assuming you have ESRI ArcMap on your machine), all you should need to do is double-click LineVisionArcMap.esriAddIn.  This should launch the ArcMap Add-In installer and automatically install the LineVision ArcMap add-in.

ArcMap Add-in Installation

If it does not automatically install, open ArcMap, select Customize > Add-In Manager and then click Customize in the window that appears.  From here, select the Add From File… button and browse to the LineVisionArcMap.esriAddIn file you downloaded.

Add-in Manager

Add-ins

Add From File

Open Add-in

Once installed, you should see the Remote Geo LineVision ArcMap toolbar appear.

LineVision ArcMap toolbar

The toolbar consists of 3 buttons. The first opens LineVision ArcMap. The second two buttons are ArcMap “Tools”. The “Click to Play Tool” enables the common features people are used to in standard LineVision — Clicking on the map point to advance the video, hovering over points to see metadata, etc.  The second tool is for adding annotations.

Because of the architecture of Esri ArcMap, we added these separate “tools” to make the two programs work together.

2.4.Registering the Software

IMPORTANT! Your LineVision Esri ArcMap software license key is unique to a specific PC and cannot be transferred. Do not enter the license key on a computer if you do not intend to use that computer with LineVision Esri ArcMap in the long term. If you need to transfer a license to a new PC please contact Remote GeoSystems.

IMPORTANT! You will need to be connected to the Internet in order to complete your one-time registration.

1. When LineVision Esri ArcMap launches, you will be prompted to enter your software license key, copy and paste the license key in the Registration window. Click the Continue button

Registration Window

2. In a few seconds you should receive confirmation that your software has been successfully registered.

 

 

2.5.Launch LineVision Esri ArcMap Add-in

To launch LineVision Esri ArcMap ArcMap Add-in click the LineVision icon on the menu bar.

ArcMap Menubar

 

3.Application Interface

IMPORTANT! This manual covers both the Pro and Viewer editions of LineVision Esri ArcMap. If a menu item or feature is only available in the Pro edition then it will be noted with Available in Pro edition Only. Please also see the Pro vs. Viewer edition feature comparison.

Once you launch the LineVision Esri ArcMap – Pro Add-In, the application appears by default with Video Viewer & Photo Viewer above the Media Browser on top of the Esri Window in the factory default layout. Like most traditional Windows programs there is also a “Menu Bar” across the top.

Default Layout

Let’s first cover the different components of the LineVision Esri ArcMap application interface.

 

3.1.Viewers and Panels

Video Viewer, Photo Viewer Panel:

This Panel will show either the Video Viewer or the Photo Viewer panel with a video stream or photo, respectively. User may select which one is displayed by clicking on the labeled tab. NOTE: When you load multiple geo-synchronized videos, you will see additional Video Viewer Panels.

Media Browser Panel:

This Panel will show a thumbnail image representing videos, photos and annotations.

NOTE: All panels are movable and can be “floating,” “docked” and resized. Simply left mouse-click the top of the panel and drag it to where you want it on the screen to float the panel. Alternatively you may “pin” the panel to one of the arrows that appears when you begin dragging the panel. You can also resize the panel by clicking on one of the edges or corners and move your mouse accordingly.

 Alternative Display Option

3.2.1.File Menu

File Menu Display

Open Video:

Select this menu item to navigate to your video. If your video has a GPS “companion file” with the same file name (but different file extension) in the same folder, or your video was recorded with the geoDVR, then your video will automatically load and zoom-in to its recorded location on the background map.

If your video’s GPS Companion File is named something different than the video file, or in a different file folder, then you will be ask to select the appropriate GPS Companion file. What this file is named may vary depending on which hardware you used to record your geospatial video and/or how you have you files named and organized.

Open Multiple Videos:

Select this menu item if you would like to open multiple geo-synchronized video files. This feature is compatible with the geoDVR, geoVISE and some other third-party multi-channel geo-referenced video recorders.  Note: Viewer edition users will be able to view multiple geo-synchronized video files that have previously been saved as a .geoProject file in Pro edition.

Open Photos:

Select this menu item to bring geo-tagged photos into LineVision Esri ArcMap. Note: You can also create geo-tagged photos from the video by pausing and “snapping a photo” from the geospatial video. These newly-created photos can then be loaded back into LineVision Esri ArcMap.

Save:

Saves your current work as a .geoProject file so that you can restore and work on it later. Note: this save function is best suited for “a project or work in progress,” as it saves your local “absolute” file paths to the media and data. For packaging and sharing .geoProjects, it is recommended you choose either the Create Uncompressed geoProject File (.geoProject File) or Create “Pack & Go” geoProject File (.rgs File) menu options.

Save All (Creates a geoProject File):

Essentially the same functionality as above and is usually used when user wants to save a .geoProject under a new name. Note: this save function is best suited for “a project or work in progress,” as it saves your local “absolute” file paths to the media and data. For packaging and sharing .geoProjects, it is recommended you choose either the Create Uncompressed geoProject File (.geoProject File) or Create ‘Pack & Go’ geoProject File (.rgs File) menu options.

Close All:

Select this menu item to close any assets such as videos, photos, documents, etc. in the Media Browser and Video/Photo Viewer. This will “reset” the application interface so that is empty as if you first opened it.

Open Remote geoProject: (.geoProject file)

Select this menu item to open a previously saved .geoProject file or Uncompressed .geoProject file on your PC, local area network or external drive.

Extract and Open a ‘Pack & Go’ geoProject: (.rgs file)

Select this menu item to extract and open a previously saved portable ‘Pack & Go’ geoProject (.rgs file).

Create Uncompressed geoProject File (.geoProject File):

Select this menu item to save your LineVision Esri ArcMap project as an Uncompressed .geoProject file which creates a geoProject with all files copied to a common directory or folder. This is the most recommended  method when saving a geoProject for sharing with a colleague or client.

Create ‘Pack & Go’ geoProject (.rgs file):

Select this menu item to save your LineVision Esri ArcMap project as a compressed or zipped .geoProject file. This method is recommended when saving a geoProject for sharing with a colleague or client and achieving the smallest possible folder size is important. NOTE: It can take several minutes or more to create a Pack & Go file, especially when your project includes large video files.

Save Current Layout & Settings as Default:

This will let you save a custom layout of the panels and will return to this layout the next time you launch LineVision Esri ArcMap.

Advanced Settings & Window Positioning

Advanced Settings menu

Load Saved Layout Settings: Select this menu to restore your custom default layout settings if you have changed them while working on your LineVision Esri ArcMap project

Reset Settings to Factory Default: Select this setting to restore the panel layout to the standard 2 panel layout

Close:

Selecting this menu item will close LineVision Esri ArcMap.

IMPORTANT! If you want to return to your current project be sure to save it as a geoProject file before exiting the program.

3.2.2.Options Menu

ArcMap Options Menu

Maintain Video Aspect Ratio:

Check this menu item if you want the video aspect ratio to remain consistent when you move and resize the video panel. (Recommended) By default this option is checked.

Limit GPS Frequency to 1 Hz:

Check this menu item if you logged video with a higher GPS frequency and want to “de-cluster” the GPS points along a path. It is recommended to leave this option checked.

Pan to Media on Click:

Check this menu item if you want the map to “pan’ to the start location of the video or point location of the plot or annotation. (Recommended) By default this option is checked.

Play on Click Settings:

Check this menu item if you want videos to begin playing from the map location at which the path was clicked. By default, Pause Video at Click Location is checked

Always Ask for GPS Companion File:

Check this menu item if you want LineVision Esri ArcMap to always ask which GPS companion file you would like to use with the video. The default is un-checked which means the application will attempt to identify companion files with the same name as the video. If LineVision Esri ArcMap does not see a GPS companion file, it will then ask you to select a corresponding companion file. Selecting this option is recommended if your GPS companion files usually have a different name than the corresponding video file.

Warn On Missing Timecodes:

Check this menu item if you want LineVision Esri ArcMap to show a warning message if timecodes are not detected in the video’s companion file. If not checked, LineVision Esri ArcMap will automatically interpolate the timecodes. Note: If timecodes are interpolated, there may be significant differences between the video position and the position on the map. By default this option is NOT checked.

Autohide Metadata Window:

Check this menu item if you want LineVision Esri ArcMap to automatically hide the metadata window when Jump To Time is selected in the LineVision Esri ArcMap Toolbar and a point is hovered over.

Check this menu item if you want LineVision Esri ArcMap to compare the length of the video to the length of the GPS points making up the video track.

Companion File mismatch menu

  • Always: When checked, the length of the video is always compared to the length of the video track. If the length is not within a tolerance, a warning message is shown.
  • Only When Edits Aren’t Possible: When checked, the length of the video is checked against the length of the video track only if the LineVision Esri ArcMap Add-in algorithm determines that the video track has not been edited.
  • Never: When checked, the video length is not checked against the video track length. It is not recommended that Never be checked unless video track editing has occurred and you know that the video’s length will not match the track length.

Turn Off Video Hardware Acceleration:

Select this menu item if you have an older computer or if you are running software that is very demanding on graphics and system resources. Since LineVision consumes a lot of resources when playing videos, you can improve the performance of your computer by leaving this menu item checked.

Auto Adjust Map for Current Video Position:

Select this menu item if you want the map to automatically pan or re-center itself when the current video position cursor (yellow balloon) moves off the screen.

Watermark Captured Images with GPS Data:

Select this menu item if you want to snap a photo from video and overlay or “watermark” the image with latitude, longitude, date, and time .

Watermark Captured Image

3.2.3.Advanced Menu

Advanced Menu

(Available in Pro edition Only)

Load GPS/Waypoint File without Video:

Select this menu item if would like to load a GPS or waypoint file without video such as a track log from a handheld GPS unit.

Extract GPS Data from geoDVR Video:

Select this menu item to create a new GPS companion file from a geoDVR video file. This is usually only used if the original geoDVR video file has been edited in an external program like Adobe Premier Pro CC or the original geoDVR video companion file has been lost. Note: This feature is only available if your video was geotagged using remote GeoSystems Patent Pending “Whisper” video geotagging method (available with geoDVR and GeoSplice.)

Launch Remote Photo GeoLocator:

Select this menu item to launch the remote GeoSystems Photo GeoLocator to geotag non-geotagged photos or to re-geotag previously geotagged photos to a new location.

Photo Geolocator

To geotag non-geotagged photos or to re-geotag previously geotagged photos:

  • Go to File > Open Photo
  • Zoom to the area of the map where you would like to geotag (geographically associate) the photo.
  • Click the Geotag Image button.

Combine Companion Files:

Select this menu item combine on more GPS companion files that were collected in chronological order.

Combine Companion Files

Repair geoDVR Video File:

The Repair geoDVR Video File is used to fix video files that become corrupt (typically from the geoDVR being shut down without recording being stopped).

 

3.2.4.Window Menu

The purpose of the Windows Menu is to let you backup and restore your application settings and custom layout. The Windows Menu is for situations where users and/or end-clients might be using multiple copies of LineVision Esri ArcMap on different PCs and need to move data files around, but also want to transfer their application settings and windows layout.

Backup Settings & Window Locations:

Selecting this menu item will let you select the folder location to save your application settings and custom layout as a .XML file.

Restore Settings & Window Locations:

Selecting this menu item will let you select the folder location where you previously saved your application settings and custom layout as a .XML file so that it can be restored.

 

3.2.5.Help Menu

Help Menu

Email Program Logs:

Select this menu item to easily report any errors should they occur while using LineVision Esri ArcMap. A window will pop up and ask you for your information. The application’s program log will automatically be attached to the email.

About:

Select this menu item to determine your LineVision Esri ArcMap software build/version number. Remote GeoSystems technical support may ask for this number when resolving support issues.

4.Viewing and Interacting with Videos & Photos

Open Video:

Select the Open Single Video or the Open Multiple Videos items in the File menu. LineVision Esri ArcMap can play up to 4 simultaneously collected geospatial video files. See Open Video and Open Multiple Videos menu descriptions in the File Menu section above for more detail.

Go to File > Open Video

Select the video file(s) you want to load.

NOTE: A GPS companion file must accompany the video file in order for it to load properly into LineVision Esri ArcMap.

Open Video Window

The video will load and begin playing. A red track will appear on Esri ArcMap in the Map Panel showing the “path” of your recorded video. A yellow marker will be moving along the video path as the video plays indicating the location where it was recorded at that moment.

After loading video

 

5.Working with Photos

Snap a Photo from Video

If something of interest is detected in the video, users may pause and “snap” a still image from the video, which is then geo-tagged and can be saved as part of a .geoProject file for data portability and future analysis. First, pause the video by clicking the Play/Pause button, then press the Photo Snap button indicated by the Camera Icon in the lower right-hand side corner of the Video Viewer panel. The Image Viewer will then appear with a geo-tagged still photo from the video.

Image Viewer Window

Inspect a Snapped Photo:

To inspect a photo select the Image Viewer and zoom into the photo using either the scroll wheel on your mouse or selecting the Magnifying Glass Icon.

Save a Snapped Photo:

To save the photo click the Save Icon to the left of the magnifying glass icon and choose the location where you would like to save the file.

Load Geotagged Photo:

To load saved the geo-tagged photos snapped from video (or other sources), select the Load Photo(s) menu item in the File Menu and navigate the folder where you saved the photos. The photos will load and be visible as thumbnails in the Media Viewer and as lime green dots on Esri ArcMap indicating where they were taken.

 

6.Image Editor (PRO)

The fully-featured image editor allows you to make many changes to captured images, without having to rely on third party software.

The following options are available:

Resize

Resize the photo, reducing the file size of it.

 

Canvas

Resize the drawing area of the photo

 

Rotate 90°

Rotates the photo 90 degrees clockwise.

 

Rotate 180°

Rotates the photo 180 degrees clockwise.

 

Rotate 270°

Rotates the photo 270 degrees clockwise.

 

Round Corners

Applies a rounded corner effect to the image.

 

Flip Horizontal

Flips the image upside-down

 

Flip Vertical

Flips the image rightside-left

 

Crop

Crops an area of the image and removes the area not selected.

 

Draw Text

Adds customizable text to the image

 

Draw

Draw lines on top of the image.

 

Shape

Add a shape to the image.

 

Hue Shift

Shifts the hue of the image, changing the colors.

 

Saturation

Shifts the saturation of the image, to make it more or less vibrant

 

Contrast

Shifts the contrast of the image, changing the contrast ratio.

 

Invert Colors

Invert the colors of the image to their opposites.

 

Sharpen

Sharpens the image. Sharpening too much can create artifacts.

 

Blur

Blurs the image.

7.Using the Waypoint Browser

The “Waypoint Browser” is triggered by right-clicking on the video icon in the Media Browser and selecting “Browse Waypoints” from the drop-down menu.

NOTE: If waypoints are not present in the video, this menu item will not appear.

Waypoint Browser

Once “Browse Waypoints” is selected, a new tab will appear next to the “Media Browser” tab (in the lower left corner of LineVision) with thumbnails (typically only with geoDVR) or a generic icon representing the different waypoint(s) will appear.

If you hover above a waypoint in the Waypoint Browser, a “marker” in pink will appear on the map showing its location.  Also, if you click on the waypoint thumbnail, the video will “jump” to the waypoint’s location.

Waypoint Marker

 

8.The Media Browser

Right clicking on an item in the Media Browser will open a contextual menu with additional options to manipulate and work with videos, files, and annotations.

Media Browser

Zoom to…:

The Zoom to… function is used when a user is trying to find the Map Viewer location that corresponds with the image, video, or audio file. Right Click on an image, video, or audio icon in the Media Browser and select Zoom too…

Fit All Media in Map (Photos and Videos)

The Fit All Media in Map function is used when the user wants to view all Media Browser files location in the Map Viewer window at once.

Jump to Time (Videos only)

The Jump to Time code function is used when a user is trying to find a section of video that corresponds to some other data type such as a gas leak detection system alert. In these cases the geoDVR and leak detection system may be logging the same GPS data stream.

Right Click on a video icon in the Media Browser and select Jump To Time or the clock icon and select a point to play from.

Input the Hour, Minutes and Seconds and click the Jump to Time button to skip to this same time in the corresponding video

Jump to Time

Remove item:

The Remove Item function will remove a file from the media browser and current project. Right Click on a file in the Media Browser and select Remove Item.

Browse Waypoints (Video and Audio Files)

NOTE: This option only appears if there are waypoints in the file.

The Browse Waypoints function is an alternate way to browse all of the Waypoints associated with the video. Right click the ‘Video” icon in the Media Browser and select “Browse Waypoints”.  Once selected, all of the Waypoints associated with the video will appear in the Waypoint Browser

 

Extract Waypoints as GPX File (Video and Audio Files)

NOTE: This option only appears if there are waypoints in the file.

The Extract Waypoints as GPX File creates a .GPX file from the Waypoints associated with a video or audio file. After you have selected Extract Waypoints as GPX File, a File Explorer window opens asking where you would like to save the GPX File

View Info

This will display details information about the item, including Start Latitude/Longitude/Altitude/Time, number of GPS Points, GPS frequency, Waypoints and other data.

View Info

9.Managing Annotations

Creating Annotations

NOTE: Only available in Pro edition

NOTE: The Basic edition will be able to view the annotations and documents created and saved with Pro edition, but will not be able to add or modify annotations or documents.

To create an annotation or note on the map simply use your mouse to right-click on the desired location on the map and then select Add Annotation

Add Annotation Toolbar icon

The Add Annotation window will appear where you can enter notes and even add additional photo images, documents and other files related to the site.

NOTE: You should be able to attach virtually any document or file format type to the map location. However, you must have a native program for that document already installed on the same PC you wish to open or modify the document or file.

Add Annotation Window

Once you click the OK button, a purple dot will appear on the map marking your annotation on the map.

Annotation dot

Working with Annotations

NOTE: When using LineVision Esri ArcMap Basic, you can only view documents and images, and cannot edit annotations.

To view an Annotation, simply click the purple dot on the map or the icon in the Media Browser to bring up the Annotation Viewer window. Once in this window, you have the option to Edit Note, Add/View/Delete Image(s), and Add/Open/Delete Document(s)

NOTE: Because LineVision is an Add-In to Esri ArcMap you must click on the pan icon to return to normal map movement.

Pan icon

Opening Annotation Documents and Files

  1. Click the purple dot on the map or double-click on pencil and notepad icon in the Media Browser to bring up the Annotation Viewer window.
  2. Select the document or image you want to open.
  3. Click on Open Document or Open Images.
  4. The native program of the image or document, such as Acrobat Reader or Microsoft Word, will open automatically.

Add a New Document or File: (Available in Pro edition only)

To add a new document or file use your mouse to right click on the desired location on the map, then select Add Annotation. Give your Annotation some notes and then click the Add Doc(s) button .

.Add Docs

Select the documents and files you would like to add to your geoProject and click the Open button in Windows Explorer. Note: You should be able to attach essentially and document or file format type to the map location. However remember you must already have the native program already installed on the same PC if you wish to open or modify the document or file

10.Using the Different Save Options

Available only in Pro edition only

Save:

This option saves your current work as a .geoProject file so that you can continue working on it later. This is the recommended method if you are leaving for lunch or the day, and will be returning to work on the project, but will not be sharing it with anyone, yet.

NOTE: this save function is best suited for “a project or work in progress,” as it saves your local “absolute” file paths to the media and data. For packaging and sharing .geoProjects, it is recommended you choose either the Create Uncompressed geoProject File (.geoProject File) or Create “Pack & Go” geoProject File (.rgs File) menu options.

Save All:

Essentially the same functionality as above and is usually used when user wants to save a .geoProject under a new name. Note: this save function is best suited for “a project or work in progress,” as it saves your local “absolute” file paths to the media and data. For packaging and sharing .geoProjects, it is recommended you choose either the Create Uncompressed geoProject File (.geoProject File) or Create ‘Pack & Go’ geoProject File (.rgs File) menu options.

Create Uncompressed geoProject File (.geoProject file):

Select this menu item to save your LineVision Esri ArcMap project as an Uncompressed .geoProject file which creates a geoProject with all files copied to a common directory or folder. This is the most recommended method when saving a geoProject for sharing with a colleague or client.

Create ‘Pack & Go’ geoProject  (.rgs file):

Select this menu item to save your LineVision Esri ArcMap project as a compressed or zipped .geoProject file. This method is recommended when saving a geoProject for sharing with a colleague or client and achieving the smallest possible folder size is important.

NOTE: Saving a compressed geoProject can take several minutes or more to create a .rgs file, especially when your project includes large video files.

11.Opening a geoProject

To open a geoProject go to File and select one of the menu items below based on how the geoProject was previously packaged.

Open a Remote geoProject (.geoProject File)

Select this menu item to open a previously saved .geoProject file or uncompressed .geoProject file on your PC, local area network or external drive.

Extract and Open a ‘Pack & Go’ geoProject (.rgs File)

Select this menu item to extract and open a previously saved portable ‘Pack & Go’ geoProject (.rgs file).

12.Important Disclaimer

REMOTE GEOSYSTEMS, INC.’s (REMOTE GEO) SOFTWARE IS PROVIDED ON AN “AS IS” BASIS, WITHOUT ANY  WARRANTIES OR CONDITIONS, EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE, OR ANY WARRANTY ARISING BY LAW, STATUTE, USAGE OF TRADE, OR COURSE OF DEALING. YOU ASSUME ALL RESPONSIBILITY AND RISK FOR THE USE OF THE SOFTWARE AND REMOTE GEO DISCLAIMS ALL LIABILITY FOR ANY LOSS, INJURY OR DAMAGE RESULTING FROM USE OF THIS PRODUCT, WHETHER DIRECT OR INDIRECT, AND WHETHER OR NOT REMOTE GEO HAS BEEN ADVISED OF OR HAS KNOWLEDGE OF THE POSSIBILITY OF SUCH LOSS, INJURY OR DAMAGE. IN NO EVENT SHALL REMOTE GEO HAVE ANY LIABILITY TO YOU OR ANY OTHER PERSON OR ENTITY FOR ANY COMPENSATORY, INDIRECT, INCIDENTAL, SPECIAL, CONSEQUENTIAL OR EXEMPLARY DAMAGES WHATSOEVER, INCLUDING, BUT NOT LIMITED TO, LOSS OF REVENUE OR PROFIT, LOST OR DAMAGED DATA OR OTHER COMMERCIAL OR ECONOMIC LOSS, EVEN IF WE HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR THEY ARE FORESEEABLE.  WE ARE ALSO NOT RESPONSIBLE FOR CLAIMS BY A THIRD PARTY. THE LIMITATIONS IN THIS SECTION SHALL APPLY WHETHER OR NOT THE ALLEGED BREACH OR DEFAULT IS A BREACH OF A FUNDAMENTAL CONDITION OR TERM OR A FUNDAMENTAL BREACH. Some states do not allow the exclusion of incidental or consequential damages or the limitation of duration of an implied warranty so the above limitations may not apply to you.

 

ANY CONTENT OR MATERIAL DOWNLOADED OR UPLOADED OR OTHERWISE OBTAINED THROUGH THE SOFTWARE IS DONE AT YOUR OWN DISCRETION AND RISK.  YOU WILL BE SOLELY RESPONSIBLE FOR ANY DAMAGE TO YOUR COMPUTER SYSTEM/NETWORK OR ANY LOSS OF DATA THAT MAY RESULT FROM THE DOWNLOAD OR UPLOAD OF ANY SUCH CONTENT OR MATERIAL OR THE USE OF THE SOFTWARE.

Suggest Edit