Map Menu – BETA

Map Menu Overview in LineVision Desktop Ultimate

Show Layer Control #

Select this menu item to bring the Layer Control tab to the front.

Layer Control tab in LineVision Desktop

Add/Change Layers #

Add or change layers in the map in LineVision Desktop.

Change Base Layer #

Select this menu item to change the base layer of the map.

Change the base layer on the map in LineVision Desktop.

This drop down menu contains the following Esri base map options:

  • World Street Map – Roads & Features
  • Imagery – Satellite/Aerial Imagery
  • Topo – Elevations & Contours
  • Ocean – Seafloor Geography & Depths

Add Layer #

Select this menu item to browse your computer and add a new layer. Select the corresponding layer type from the dropdown.

Supported layer types:

  • Annotation Layer
  • Dimension Layer
  • Feature Layer
  • GeoPackage Layer
  • Integrated Mesh Layer
  • Kml Layer
  • Map Image Layer
  • Ogc 3D Tiles Layer
  • Point Cloud Layer
  • Raster Layer
  • Shapefile Layer
  • Tiled Layer
  • Vector Tiled Layer
  • Web Tiled Layer

Add new layer to the map in LineVision Desktop.

Load Leak Detection KML/KMZ File #

Select this menu item to browse your computer and load a Boreal Laser or other gas leak detection system (LDS) KML or KMZ file.

Load Custom KML/KMZ File #

Select this menu item to load a custom KML or KMZ file. For example, data might include pipeline leak-detection sensor data, utility & pipeline asset network, patrol waypoints, or vector & imagery data.

NOTE: KML/KMZ files imported into LineVision Desktop may not display all the data elements visible in LineVision Google Earth.

NOTE:  Data added to the session through the Add/Change Layers functionality can be saved as part of a geoProject.

GPS Point & Labeling Settings #

GPS Point and Labeling Settings in LineVision Desktop

Current Position Icon #

Size #

The menu item lets you select between Small, Medium and Large icon sizes.

Current Position Icon sizes in LineVision Desktop.

Graphic #

This submenu offers a variety of options for the type of vehicle used to capture data. By default, the circular yellow marker is selected.

  • Helicopter
  • Vehicle
  • Boat
  • Bike
  • Motorcycle
  • Person
  • Default

Current Position Icon Graphic in LineVision Desktop.

Show GPS Point Labels #

If you have previously labeled GPS points by right-clicking the GPS video track, select this option to display the labels. Uncheck the box to hide the labels.

GPS point labels when the "label GPS points" box is checked.

Labels on the map

Labels are hidden when the box is unchecked.

Labels Hidden

Set GPS Point Labels Font Size #

Set the map text display settings.

Map Display Text Settings in LineVision Desktop.

Set Video Track & Waypoint Size #

Set the size that video points and waypoints will appear on the map.

Waypoint and Map Point Sizing in LineVision Desktop.

GPS Point Info Box Display Options #

GPS point info box labeling settings in LineVision Desktop.

This submenu contains various options on how to display GPS Point info when hovering over the GPS track with the cursor.

Always Show Info #

Select this option if you would like to see a pop up box with detailed GPS point information each time you hover over a GPS point along the video’s track.

Hide if MISB/Camera Target is Present #

Select this option to hide the above pop up box when the video contains extra camera orientation metadata such as MISB FMV/STANAG 4609-spec or Remote GeoSystems Camera Target Footprint (CTF) protocol.

Never Show Info #

Select this option to always hide the above pop up box.

Esri #

The Esri menu in LineVision Desktop.

Authenticate with Esri OAuth #

Log in to your Esri account to access ArcGIS Online. This allows you to download and use additional data from your Esri account. You will need to be logged into your Esri account to use both online and local Esri data files.

Sign into Esri OAuth to access your Esri account through LineVision Desktop.

Browse ArcGIS Online Items #

After logging into your Esri account using Authenticate with Esri OAuth, you can select this menu item to browse ArcGIS Online and add additional data to LineVision Desktop.

Enter Esri Runtime License #

Select this menu item to enter an Esri runtime license key if applicable.

Enter your Esri Runtime License if applicable

Reset Esri Runtime License #

Select this menu item to delete a previously-entered Esri runtime license key and enter a new one if applicable.

Advanced Map Settings #

Advanced Map Settings in LineVision Desktop

Set to World View #

Select this option to pan the Map Viewer to a view of the entire world when the software starts.

NOTE: After selecting this option, remember to save your settings under File > Settings & Layout > Save Current Settings & Layout as Default.

Set to United States View #

Select this option to pan the Map Viewer to a view of the continental United States when the software starts.

NOTE: After selecting this option, remember to save your settings under File > Settings & Layout > Save Current Settings & Layout as Default.