August 22, 2019

Live Moving Maps

The optional geoDVR Live Moving Maps module lets you load and save mission-specific asset map files to the geoDVR Map Window. This functionality is used to assist in locating non-obvious and hard-to-find linear assets and places such as buried pipelines, power line structures, cell towers, wildfire boundaries, wildlife habitats, etc. It provides airborne and mobile camera operators a simple and reliable way to monitor current position in relation to where they are supposed to be for any given mission.

Prior to taking flight, operators simply take relevant shapefiles or KML (we find KML usually works best) provided by your GIS Department and directly load them to the geoDVR Map Window panel. Now with the map data loaded to the geoDVR Map Window, camera operators can geospatially reference their data collection target on the map interface while also observing their current aircraft, vehicle or vessel position as it moves along the selected shapefile or KML data in real-time.

Equally important to understanding Live Moving Maps, understanding what it is NOT:

It is NOT designed to take the place of true aircraft navigation systems and avionics.

It is NOT designed to store all of an organizations’ GIS maps and asset location data files for instant access from the geoDVR.

It is NOT a video “augmented reality system” or ARS with the map data overlaid directly on the live video feed(s).

Referring to the screenshot below, if your geoDVR is equipped with the optional Live Moving Maps module your screen may look similar to the following screenshot upon booting up the geoDVR.

NOTE: Your actual interface may vary depending on number of video channels and/or if you have previously changed and saved your layout using the File menu option.

If you believe your geoDVR is configured with Live Moving Maps, but you do not see the Map Window or Map Layer Control panels, please try going to the Window menu item and select Map Window and/or Map Layer Control and these panels should now reappear in the geoDVR interface.

Exporting Properly-formatted Data Files from GIS for Use with geoDVR Live Moving Maps

Remember the primary purpose of the Live Moving Maps module is tracking your current position in relation to asset location data files. With this is mind it is important to understand some parameters for exporting data in the proper format for use in Live Moving Maps as well as working with multiple data files loaded at once.

It is important to keep your files small in size to optimize the geoDVR’s video recording, GPS and mapping capabilities. For this reason it is very important that you only export shapefiles and KML with the most critical information needed for the inspection, observation or patrol mission. By default the geoDVR is set-up to only accept a single map data file with 500 “elements” or less. You can load more than one map data file, but each individual data file should have 500 elements. (If you believe you need more elements in a single file for your mission please contact your Remote GeoSystems representative to discuss the feasibility of increasing that limit.)

For example, if you are conducting a power line inspections, we advise exporting individual files for each line to be inspected with only a few pieces of critical attributes such as; line name, tower/pylon locations and Field ID or structure number for each tower/pylon. Do NOT expect to load your entire transmission and distribution network as a single file with all asset attributes – it will most likely not work.
Similarly if you are doing shoreline or trail mapping, only export lakes or trails for a small area of your region, such as a small county. Do NOT expect to load all geographical features as a single file with all kinds of metadata attributes – it will most likely not work.

Once you feel you have exported a properly-formatted KML or shapefile save the files to a USB thumb drive or external hard drive so they can be moved over to the geoDVR hardware.

Adding New Map Layers to the geoDVR Live Moving Maps Interface

NOTE: It is recommended to have a wired mouse and keyboard connected to the geoDVR when copying data to the unit.

  1. With the geoDVR booted up and geoDVR interface running, close the main geoDVR interface by selecting “File > Exit geoDVR Screen
  2. Once the geoDVR interface is closed, and you see the Windows desktop, insert the thumb drive and copy over KML or Shapefile data to a folder on the geoDVR desktop.

Now that you have loaded the data to a folder on your geoDVR’s system drive, you will need to add it to the Live Moving Maps interface.

  1. In the main geoDVR interface, click on the Map Layer Control tab underneath the Live Moving Maps display panel.
  2. Click the Add New Layer button
  3. Give the new layer a name, and select the Layer type depending on the data you wish to load in (KMLFile or Shapefile)
  4. Click the Browse button and select a data file you loaded earlier, .KML and .SHP are supported at this time.
  5. Referring to the image below, you will see the loaded data elements on the map as a new layer. If you wish, you can adjust the transparency by clicking on the new layer and moving the slider.