Drill Down Waypoint Descriptions

Drill Down Waypoint Descriptions Menus #

File Menu #

This menu is in the upper right of the Waypoint Descriptions Menu Builder panel.

The Waypoint Description Menu Builder has its own File menu.  These are the menu options:

Save Waypoint Tree

Select this option to save a Drill Down Waypoint Description Menu.

Save Waypoint Tree As...

Select this option to save a Drill Down Waypoint Description Menu with a new name.

Open Waypoint Tree

Select this option to open a Drill Down Waypoint Description Menu for editing.

Clear Tree

Select this option to cancel the current Drill Down Waypoint Description Menu being created/edited.

Close Waypoint Menu Builder

Select this option to close the current Waypoint Description Menu Builder window.

Button Right-click Menu #

This menu will appear when right-clicking to add buttons.

Add New Button

Select this option to add a new button.

Delete Selected Button

Select this option to delete the button.

Rename Selected Button

Select this option to change the button label.

Add Description (optional) 

Select this option to add a more long form test description to be applied when the last button in a drill down sequence is selected.  If  a description is not added, the button’s name will appear as the Waypoint Description.

Build Drill Down Waypoints Descriptions #

If using this feature in the LineVision Desktop software go to Advanced > Launch Waypoint Description Drill Down Menu Builder.

If using this feature in the geoDVR or geoDSR interface go to Waypoints Descriptions > Build Waypoint Description Drill Down Menu.

The Waypoint Descriptions Menu Builder window will appear.

Referencing the image below, right-click the grey Start Screen bar.  Select Add New Button to add a new top-level button to the initial start screen that will appear when the waypoint button is pressed.

Alternatively, select Add Prompt for User Text Input Button to create a button that will initiate an area to enter free-form text.

Referencing the image below, enter the name of the waypoint description button and click the OK button.

 

Referencing the image below, to add a “drill down” button under the start screen button, right-click the top-level button name under the Start Screen (in this case “ROW Issue”).  Select Add New Button to add a new button under the above button.

NOTE:  After the initial Start Screen button, the right-click menu now includes some additional options.  These options are described in the Menus section above.

Referencing the image below, an “Equipment” button was added under the start screen “ROW Issue” button.

Repeat the above steps as needed to finish adding any additional down level-level buttons.

For example, referencing the image below, you could create third-level “Bulldozer”, “Excavator” and “Compactor” buttons to select from after the “Equipment” button is selected.

 

When done creating your Drill Down Waypoint Description Menu, click Save & Close.

NOTE:  When building the Waypoint Description Drill Down menu in the geoDVR interface or LineVision Desktop, by default users will usually be prompted to a folder called “AdvancedWaypointMenuLayouts” to save the new menu.

If building and saving in the geoDVR, the file path will usually be something like  C:\Users\Desktop\AdvancedWaypointMenuLayouts

If building and saving with LineVision Desktop software, the file path will usually be something like  C:\Users\UserName\Documents\AdvancedWaypointMenuLayouts

Enter a name for the menu and click Save.  The menu will have the “.rgsWptBuilder” file extension.

Import Waypoint Drill Down Menu Template #

To import a custom Waypoint Description Drill Down menu for use in the geoDVR interface, go to Waypoint Descriptions menu > Import Waypoint Description Drill-Down Menu Template.  Navigate to the AdvancedWaypointMenuLayouts folder (or other folder where the menus have been saved), select the menu file(s) and click Open.

Enabling & Using the Drill Down Waypoint Descriptions #

IMPORTANT: To use the module, you will need to go to the Options menu and be sure Disable Popup Message Alerts is unchecked, otherwise the Waypoint keyword selection windows will be blocked.

Go to Options >Disable Popup Message Alerts

 

Additionally, go to Waypoint Descriptions > Waypoint Description Entry > and be sure Use Waypoint Drill Down Menu is checked.

 

Be sure Use Waypoint Drill Down Menu is checked

 

Go back to the Waypoint Descriptions menu and there should now be an option for Waypoint Description Template.  Clicking this option allows users to select and check which of the imported the Drill Down Waypoint Descriptions menus they would like to use for the specific mission or project.

 

Your template will be visible under Waypoint Description Template

 

IMPORTANT:  Once making the above selections, before closing the geoDVR interface you must save using the File menu > Save Current Layout if you want the selection to persist after restarting the geoDVR interface.

 

File > Save Current Layout

 

You are now ready to use the Drill Down Waypoint Descriptions while recording geotagged video in-mission.

Feature Availability #

These Remote GeoSystems solutions support building drill down waypoint description menus: